Deadline To Disable TLS/SSL

 
 
January 24th, 2018

Deadline To Disable TLS v1, SSL v2 & SSL v3

SSL / TLS

Websites using an older version of Transport Layer Security (TLS) and Secure Sockets Layer (SSL) will soon be out of compliance. To avoid violation of the PCI Data Security Standard (PCI DSS) for safeguarding payment data, you must upgrade to a later version of TLS (v1.1 or higher, TLS v1.2 is strongly encouraged) by the June 20, 2018, deadline.

Please Note: Migration to more secure protocols takes time, therefore time is of the essence. 

Contact Us to find out more.

About the writer.

 
Jeremy Sherman
Jeremy Sherman
Executive Assistant
 

Ready To Take The Next Step With Us?